FAQ

IPv6 LoRaWAN Adaptation Layer FAQ

Issue link: https://read.uberflip.com/i/1499940

Contents of this Issue

Navigation

Page 2 of 6

5177 Brandi n Court, Frem ont, CA94538 | Tel : +1 51 0 -4 9 2 -4044 | Fax : +1 510 -4 9 2 -4001 | www.l o ra -al l i anc e.org IPv6 LoRaWAN Adaptation Layer FAQ network side. SCHC management is up to both the operator and end-device manufacturer/ integrator. While there are several possible ways to manage rules, the most critical point is that the end-device and the SCHC gateway always share the same rules. A YANG data model (RFC9363) formally specifies the semantic of the SCHC rules, allowing to validate a candidate rule set against the model. 8. Where can I find the SCHC specification? SCHC is defined in RFC8724, which specifies the generic SCHC framework without referring to any specific LPWAN technology. In order to ensure efficiency and interoperability, RFC9011 defines a profile for SCHC over LoRaWAN®. The LoRa Alliance® provides directions to support IPv6 over LoRaWAN® in TS010. 9. What is the maximum packet size that SCHC can support? The SCHC over LoRaWAN profile ensures that the minimum IPv6 link Maximum Transmission Unit (MTU) of 1280 bytes is respected. Even better, it actually provides an MTU of 2520 bytes uplink, and does not place any theoretical limit on the downlink MTU of the packet delivered to the SCHC layer. 10. Does SCHC affect LoRaWAN security? As explained in How does SCHC operate on top of LoRaWAN?, SCHC operates over LoRaWAN as any other application does. Therefore, SCHC does not alter the intrinsic security properties of LoRaWAN. SCHC itself, as any application over LoRaWAN, undoubtedly extends the attack surface of the system, both at the end device side and at the network core side. Compression/decompression protocols and fragmentation/reassembly protocols are subject to well-known attack mechanisms. Section 12 of RFC8724 lists them and explains why they can't happen with SCHC or how they are mitigated. 11. How does SCHC operate on top of LoRaWAN? The SCHC protocol operates between two SCHC entities, one located in the end-device and the other in the server side as presented in 2. What is the architecture overview of SCHC? The two instances communicate by sending SCHC messages over LoRaWAN layer 2 as any regular application would, i.e., with FPort values in the regular application range [1..223]. Each type of SCHC messages uses its own FPort value. For example, downlink fragmentation uses FPort value 21 (recommended value) for its messages, and uplink fragmentation uses FPort value 22

Articles in this issue

Links on this page

view archives of FAQ - IPv6 LoRaWAN Adaptation Layer FAQ